dkfr.net
当前位置:首页 >> 浏览器iE8不支持用jquEry吗 >>

浏览器iE8不支持用jquEry吗

2.0以上版本的jQuery已经不再支持IE8及以下版本的IE浏览器,所以才出现了问题。 解决方法很简单: 相关问题: Jquery从2.x版本开始已经不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。如果需要兼容低版本的IE版本,建议使用原生JS或者低版本的Jqu...

当然有不兼容的地方啊,但只是极少数地方,也要看看你的jquery包都是哪个版本的~ 建议用1.8.3版本最稳定,1.4.3也是个稳定版本。但用新不用旧还是1.8.3吧,2.0后都不支持IE 6 7 8了

jquery10中$.browser方法已经废弃了 jquery现在只能检测浏览器是否支持某特性, 业界也推荐这么做 html5的新特性ie8以下不支持, 所以可以用下面的方法进行判断 $.support.leadingWhitespace 如果是false, 就是ie8及以下, 如果是true, 就是新的浏...

你好,很高兴为你作答。 对于IE 8 来说,jquery的低版本是可以兼容的。 不过在2.0版本之后,官方已经宣布不再支持IE 6 7 8版本的浏览器。 所以,使用诸如比较常用的1.4、1.7版本的jquery,在IE 8下面使用是没有问题的。

jQuery新版本已经不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。 如果项目需要兼容IE低版本,需要使用jQuery1.x版本,从2.x开始已经不兼容IE6、7、8了。 以下为jQuery官网的通知: jQuery 2.x has the same API as jQuery 1.x, but does not su...

解决方案1: 就是新的浏览器, 就是ie8及以下, 业界也推荐这么做 html5的新特性ie8以下不支持jquery10中$, 所以可以用下面的方法进行判断 $, 包括firefox.support.browser方法已经废弃了 jquery现在只能检测浏览器是否支持某特性, chrome.leading...

jquery2.0版本以上不再支持IE8以下,试下用jquery1.10

if(navigator.appName == "Microsoft Internet Explorer" && navigator.appVersion .split(";")[1].replace(/[ ]/g,"")=="MSIE6.0") { alert("IE 6.0"); } else if(navigator.appName == "Microsoft Internet Explorer" && navigator.appVersio...

这样你把错误打出来? error:function(a,b,c){ alert(这三个参数打出来); } 这样打出来你看看 返回错误是什么?

jQuery从2.0版开始不再支持IE6、IE7和IE8. 请引用2.0以下的版本即可.

网站首页 | 网站地图
All rights reserved Powered by www.dkfr.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com