dkfr.net
当前位置:首页 >> IE8下不支持jquEry绑定的CliCk事件怎么破 >>

IE8下不支持jquEry绑定的CliCk事件怎么破

楼主不说明使用版本,猜测可能是版本的问题。 复制一段 jQuery 官网的原话: jQuery 2.x has the same API as jQuery 1.x, but does not support Internet Explorer 6, 7, or 8. 2.x 版本不兼容 IE6,7,8 网上也有一个。 博客园闪存分页是用Jav...

click还是支持的不知道你是怎么绑定的?jquery版本是多少? $(#selector").click(function(){ }); 应该没问题 如果用$("selector").bind("click",function(){ }); 高版本的jquery取消了bind

click还是支持的不知道你是怎么绑定的?jquery版本是多少? $(#selector").click(function(){ }); 应该没问题 如果用$("selector").bind("click",function(){ }); 高版本的jquery取消了bind

2.0以上版本的jQuery已经不再支持IE8及以下版本的IE浏览器,所以才出现了问题。 解决方法很简单: 相关问题: Jquery从2.x版本开始已经不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。如果需要兼容低版本的IE版本,建议使用原生JS或者低版本的Jqu...

jQuery下使用removeAttr时,在IE8以下版本中会出现属性移除不了的问题,现象是移除以后,仍然显示为disabled的状态,但文本框可录入,按钮可点击,严重的是,数据提交不了。 修正的方法是使用prop方法,如 $('#needDisabledElem').prop("disable...

当然有不兼容的地方啊,但只是极少数地方,也要看看你的jquery包都是哪个版本的~ 建议用1.8.3版本最稳定,1.4.3也是个稳定版本。但用新不用旧还是1.8.3吧,2.0后都不支持IE 6 7 8了

你好,很高兴为你作答。 对于IE 8 来说,jquery的低版本是可以兼容的。 不过在2.0版本之后,官方已经宣布不再支持IE 6 7 8版本的浏览器。 所以,使用诸如比较常用的1.4、1.7版本的jquery,在IE 8下面使用是没有问题的。

jquery2.0版本以上不再支持IE8以下,试下用jquery1.10

没有以ie8为分割线的版本. jQuery 1.9及以下的版本支持IE的所有版本 1.9以上版本不再支持IE9以下版本

一行代码解决各种IE兼容问题,IE6,IE7,IE8,IE9,IE10 在这里送上几种IE使用模式: 1、 2. Google Chrome Frame也可以让IE用上Chrome的引擎: 3.强制IE8使用IE7模式来解析 //或者 4.强制IE8使用IE6或IE5模式来解析 5.如果一个特定版本的IE支持所要求...

网站首页 | 网站地图
All rights reserved Powered by www.dkfr.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com