dkfr.net
当前位置:首页 >> JS与IE8兼容问题 对象不支持此属性或方法 >>

JS与IE8兼容问题 对象不支持此属性或方法

你可以在网页头部上加上兼容信息,让IE默认就按照兼容性视图的方式来显示你的网页,这样就不会有问题了,,具体方法你可以看考这里http://technet.microsoft.com/zh-cn/library/ff955640(WS.10).aspx

jquery2.0版本以上不再支持IE8以下,试下用jquery1.10

id为reg_domain_hidden的是什么标签,有text属性么?用val赋值试试呢

可以换jquery1.10版本,如果只是一些少用的方法不支持,可以针对IE做一下兼容

1、打开IE浏览器点击“工具”——>选择“Internet选项”——>选择“安全”——>点击“默认级别(D)”——>点击“应用”——>再切换到“高级”选项卡中——>将“禁用脚本调试(Internet Explorer)”、“禁用脚本调试(其他)”前面两项打上勾——>点击“确定”退出; 2、如果系统中安...

尽量用高版本!支持性 兼容性 都好些!

估计是你ie版本的问题,ajax,必须支持不同的浏览器,ie6,ie7,ie8,ff

你可以在网页头部上加上兼容信息,让IE默认就按照兼容性视图的方式来显示你的网页,这样就不会有问题了,,具体方法你可以看考这里http://technet.microsoft.com/zh-cn/library/ff955640(WS.10).aspx 相关问题网上有的

你确定你是在这个标签里写的代码? var a = "abcdefg"; var index = a.indexOf("b"); alert(index); 一个小例子,完美运行。 我猜你没有确定使用的脚本类型,就是script中的type。

网站首页 | 网站地图
All rights reserved Powered by www.dkfr.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com