dkfr.net
当前位置:首页 >> iE8 不兼容jquEry vAliDAtE.js 怎么解决 >>

iE8 不兼容jquEry vAliDAtE.js 怎么解决

http://download.csdn.net/download/cjiany/5759351 我也遇到了这个问题,然后找到了这个可以兼容IE6,7,8.的js IE8 我已经测试过了可以用的 你可以下载用一下试试

以前在远标学习时也遇到过:只需在jquery.validate.js 文件中找到 return $([]).add(this.currentForm.elements).filter(":input") 更换成 var listeElements = new Array(); for(var k=0;k

一行代码解决各种IE兼容问题,IE6,IE7,IE8,IE9,IE10 在这里送上几种IE使用模式: 1、 2. Google Chrome Frame也可以让IE用上Chrome的引擎: 3.强制IE8使用IE7模式来解析 //或者 4.强制IE8使用IE6或IE5模式来解析 5.如果一个特定版本的IE支持所要求...

表单在HTML中占据着重要的地位,在客户端对表单进行验证也是前端工作中非常重要的一个环节,在这种形势下表单验证插件也应用而生,其中最为杰出的要数 jQuery Validate。 但是与很多常见的插件一样,对于IE9之下的浏览器支持度并不好。 今天tity...

你好,很高兴为你作答。 对于IE 8 来说,jquery的低版本是可以兼容的。 不过在2.0版本之后,官方已经宣布不再支持IE 6 7 8版本的浏览器。 所以,使用诸如比较常用的1.4、1.7版本的jquery,在IE 8下面使用是没有问题的。

1.可以使用原生JS或者低版本的Jquery1.x版本。因为Jquery从2.x版本开始已经不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。如果需要兼容低版本的IE版本,建议使用原生JS或者低版本的Jquery1.x版本。 2.可以给网页写两套或者多套JS代码以适应不同...

当然有不兼容的地方啊,但只是极少数地方,也要看看你的jquery包都是哪个版本的~ 建议用1.8.3版本最稳定,1.4.3也是个稳定版本。但用新不用旧还是1.8.3吧,2.0后都不支持IE 6 7 8了

类似案例更改、你的是什么业务代码行触发的这个错? success: function(data){ $('#my_name_id').find('option').remove().end().append(data.select_options); }//改为success: function(data){ if( $('#my_name_id').is('select') ) { $('#my_...

jquery2.0版本以上不再支持IE8以下,试下用jquery1.10

你可以在网页头部上加上兼容信息,让IE默认就按照兼容性视图的方式来显示你的网页,这样就不会有问题了,,具体方法你可以看考这里http://technet.microsoft.com/zh-cn/library/ff955640(WS.10).aspx

网站首页 | 网站地图
All rights reserved Powered by www.dkfr.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com