dkfr.net
当前位置:首页 >> jquEry不兼容低版本iE浏览器怎么解决办法 >>

jquEry不兼容低版本iE浏览器怎么解决办法

Jquery从2.x版本开始已经不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。如果需要兼容低版本的IE版本,建议使用原生JS或者低版本的Jquery1.x版本。 一般的处理方式是给网页写两套或者多套JS代码以适应不同版本、不同类型的浏览器,然后使用原生J...

1.可以使用原生JS或者低版本的Jquery1.x版本。因为Jquery从2.x版本开始已经不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。如果需要兼容低版本的IE版本,建议使用原生JS或者低版本的Jquery1.x版本。 2.可以给网页写两套或者多套JS代码以适应不同...

是报这样的错吧: undefined is not a function; 因为1.9之后移除了toggle。 以下来自网络: jQuery 1.9较之前版本的变化,主要介绍移除方法的替代方法:.browser、.live、.die、.sub、.toggle 简介: 本文档是一次调研总结,直接贴过来的,没...

首先你确定ie低版本兼容html5?ie9一下版本都不支持html5,你还考虑jQuery干嘛!

用这个框架 最好就别考虑低版本兼容性 因为做这个框架的估计都不考虑了,你要考虑 就要另外写兼容脚本. 不划算 如果兼容低版本 可以找低版本的UI框架使用

你可以试一下 jquery别名,(在第一个jquery引入代码下面,写下面这行代码,然后在这行代码下面再引入其他版本的jquery。) 第一次引入的jquery,调用的时候写 $j('#id')。 JQuery.noConflict()这个是专门解决冲突的,往采纳。 var $j=JQuery.no...

样式: #ie6-warning{ background:#FFC; position:absolute; top:0; left:0; font-size:12px; color:#f00; width:100%; line-height:24px; text-align: center; z-index: 100000000; } #ie6-warning a { text-decoration:none; } 这个只是IE6的

基本都是兼容的。 我也遇到过不兼容的问题。相近的版本兼容性高,不相近的兼容就很差的。

测试if(navigator.appName == "Microsoft Internet Explorer" && navigator.appVersion .split(";")[1].replace(/[ ]/g,"")=="MSIE6.0" || navigator.appName == "Microsoft Internet Explorer" && navigator.appVersion .split(";")[1].replace...

官网上面有非常详细的说明,你可以去看一下。

网站首页 | 网站地图
All rights reserved Powered by www.dkfr.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com