dkfr.net
当前位置:首页 >> jquEry在IE8下错误... >>

jquEry在IE8下错误...

var kx_shipping = $("input[class=tradio]:checked").parent().next().text(); 声明的有问题吧 html()是替换ID为shipping元素下的html代码 而你kx_shipping声明出来的值只有在这个script闭合元素下才能执行 ID为shipping元素里面的值只能是html...

jquery2.0版本以上不再支持IE8以下,试下用jquery1.10

jQuery从2.0版开始不再支持IE6、IE7和IE8. 请引用2.0以下的版本即可.

可以换jquery1.10版本,如果只是一些少用的方法不支持,可以针对IE做一下兼容

你好,很高兴为你作答。 对于IE 8 来说,jquery的低版本是可以兼容的。 不过在2.0版本之后,官方已经宣布不再支持IE 6 7 8版本的浏览器。 所以,使用诸如比较常用的1.4、1.7版本的jquery,在IE 8下面使用是没有问题的。

当然有不兼容的地方啊,但只是极少数地方,也要看看你的jquery包都是哪个版本的~ 建议用1.8.3版本最稳定,1.4.3也是个稳定版本。但用新不用旧还是1.8.3吧,2.0后都不支持IE 6 7 8了

ie来说 你jquery语法必须规范化,否则就报错。当初ajax我就碰到不能使用url链接参数传递,报错。

重置一下IE,打开IE,工具,INTERNET选项,高级,还原默认设置,然后清除一下你的IE临时文件,不行换个浏览器看看?如果别的浏览器没有问题,建议重装一下你的IE。

jquery也是分为两个版本 1.x版本可以兼容IE 2.x版本只有高版本IE才可以兼容

没有以ie8为分割线的版本. jQuery 1.9及以下的版本支持IE的所有版本 1.9以上版本不再支持IE9以下版本

网站首页 | 网站地图
All rights reserved Powered by www.dkfr.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com